2.12.2013

Running Tor in openwrt [tp link mr 3020]

running tor in bactrack it's easy...but how about running tor in ur router, 
i might be more excited. imagine u use inet connection together but all connection being relay into tor connection...
ok... let's start our engine 

fisrt, install all required packet
 
opkg update
opkg install tor-alpha-openwrt
opkg install tor-alpha-openwrt-geoip
opkg install iptables-mod-nat-extra 
 
this sections below is part my config files:
/etc/conf/network:
config interface tor
        option ifname   "ath0"
        option proto    static
        option ipaddr   192.168.1.1
        option netmask  255.255.255.0

/etc/config/dhcp:
config dhcp tor
    option interface    tor
    option start     100
    option stop    150
    option leasetime    12h

/etc/config/firewall:
config zone
        option name     tor
        option input    REJECT
        option output   ACCEPT
        option forward  REJECT
        option syn_flood 1
        option conntrack 1

#open the port of the DHCP-Server, so that the clients get an ip
config rule                                
        option src              tor        
        option proto            udp        
        option dest_port        67         
        option target           ACCEPT     
#TOR transparent-proxy-port (set in /etc/tor/torrc)                                           
config rule                                
        option src              tor        
        option proto            tcp        
        option dest_port        9040       
        option target           ACCEPT     
#TOR DNS-proxy-port (set in /etc/tor/torrc)                                            
config rule                                
        option src              tor        
        option proto            udp        
        option dest_port        9053       
        option target           ACCEPT
 
/etc/firewall.user:
iptables -t nat -A PREROUTING -i ath0 -p udp --dport 53 -j REDIRECT 
--to-ports 9053 #redirects all DNS-requests on the interface ath0 to the 
tor-daemon-dns-proxy-port
iptables -t nat -A PREROUTING -i ath0 -p tcp --syn -j REDIRECT 
--to-ports 9040 #redirects all tcp-requests on the interface ath0 to the 
tor-daemon-transparent-proxy-port


/etc/tor/torrc:
VirtualAddrNetwork 10.192.0.0/10             
AutomapHostsOnResolve 1                                              
TransPort 9040                                                          
TransListenAddress 192.168.1.1                                          
DNSPort 9053                                                              
DNSListenAddress 192.168.1.1

/etc/conf/wireless:
config wifi-device  wifi0
    option type     atheros
    option channel  auto

    # REMOVE THIS LINE TO ENABLE WIFI:
#    option disabled 1

config wifi-iface
    option device    wifi0
    option network    tor
    option mode    ap
    option ssid    'Piratebox'
    option encryption none


Twitter Delicious Facebook Digg Stumbleupon Favorites More